MoP won't install

Discussion in 'Tech Support' started by Fireeater, Sep 26, 2012.

  1. Fireeater

    Fireeater Member

    I have been stuck at the first updating stage since Monday night. It gets about one third through and then just never makes any more progress.

    Things I have tried:

    1. Letting it run all day or night.
    2. Run as admin.
    3. Run from admin account.
    4. Delete cache, wtf and interface folders.
    5. Made sure firewall allows wow launcher through.
    6. Double checked that MoP is paid for and enabled.

    At this point I get to that one third stage in less than a minute, then stuck again.

    The tech support forum has no other ideas for me that I can find. Will be perusing others as best I can while on the bus to and from work.

    Anyone got some ideas?
     
  2. Fireeater

    Fireeater Member

    Well, it's still not working, but here is what I have found so far:

    In some thread on tech support, a guy said he was told to delete the "agent" file but it still wasn't working, and had gotten nothing but "me, too!" replies. I googled "what happens if I delete the agent file in wow?" and it came up with this thread:

    http://us.battle.net/wow/en/forum/topic/4511762211

    It seems to have the best info I have found. Here's a cut and paste. I tried just deleting "agent" and that hasn't worked. Later tonight, if I have time (Adam has a concert so I won't be home until 9ish), I will try the fuller solution.

    Note this was about the launcher for MoP being buggy back in APRIL. *sigh*

    Introduction:

    • "Updating Setup Files" getting stuck is a bug in the new launcher used by MoP beta, D3 beta (and live soon™). It is a fairly new shared launcher that eventually will be used by all blizzard games. It still has some issues to work out but they have made progress with it during these betas. "Updating Setup Files" should never take that long, if you're stuck on this for hours, your setup is very much stuck. All this process is, is setup, updating itself, making sure the battle.net folder, which consists of Launcher application and Agent application, are all in order. After this process it should enter a new process and show an actual launcher window related to whatever app you opened it with (D3, MoP)


    First off, possible causes of the issue:.
    Cause One:

        • Caused by p2p option being turned on. It can often result in agent (sub process of launcher) to sit there seeding with so much bandwidth, it's unable to actually download anything (i.e. only uploading). If this bug happens to you, your setup will NEVER complete but max out your upload the entire time it sits there. Because you cannot access the p2p option until AFTER this process completes, you cannot actually fix the problem without first fixing the problem, paradox huh?.
    Solution One:

        • Well there is another way to fix the problem, you can change the setting manually by editing agent.db file (or replacing it with one that's already edited). Since replacing is easier to explain, i'll just mention that vs how to edit the file manually.
        • a. Make sure launcher/agent is closed and D3/WoW are not running. In Mac OS X, open Activity Monitor from applications/utilities folder and sort p rocesses by name and kill agent or launcher or diablo3 or World of Wacraft if any of then are stuck open (and if properly exiting them failed). In Windows, press control-alt-delete and do same with task manager, look for any of those processes and kill them before we begin.
        • b. Download working file from here http://www.mysticalos.com/agent.zip
        • c-1. Windows: Navigate to where your broken one is. It will be in one of a few locations. "C:\ProgramData\Battle.net\Agent\Agent.db" or "C:\Users\Public\Battle.net\Agent\Agent.db" or "C:\Documents and Settings\All Users\Application Data\Blizzard Entertainment\Battle.net\Agent\Agent.db". (ProgramData is default if you did not change install default install location) This folder is also HIDDEN by default. Which means going into folder options and selecting "show hidden files and folders" to find it. "Agent.db" might just be agent if you also have "hide known suffixes enabled". So while in folder options i recommend turning that off too. Because there are multiple files named agent. There is agent.exe, agent.dat and agent.db all in the agent folder.
        • c-2. Mac OS X: Navigate to where your broken one is and open folder. It will be in in "harddrive/users/shared/battle.net/agent/"
        • d. Once you find "Agent.db" in your agent folder, replace it with one you got from my site (after you unzip it).
        • e. Rerun launcher from D3 or MoP folder (do not manually open it from the battle.net folder), it should still do "Updating Setup Files", but now it will finish quickly and not get stuck on uploading to everyone on the internet and not downloading anything.

    Cause Two:

        • Agent.db file is corrupt, this causes launcher to return to "updating setup files" even though it's already been completed previously.
    Solution Two:

      • This can be resolved by just deleting agent.db and then rerunning launcher, it'll make a new one. It might scare you and say it's downloading from 0% again, but just wait. Since you deleted agent.db it doesn't remember what's already downloaded. It's going to scan folder, and go "oh it's all there" and then finish up real fast. Now, if you're a person who's also affected by issue 1, deleting agent.db will also revert p2p to being back on. So if you get issue 2, to avoid issue 1 just coming back. you can just follow the steps to fix issue one to also fix issue 2. My uploaded agent.db file doesn't just have p2p off, it's also a blank slate that will fix agent.db corruption for both D3 and MoP. So essentially, you can just download the zip once, keep it handy somewhere, and unzip your fix any time issue 1 and 2 come up. :)
     
  3. Fireeater

    Fireeater Member

    Well, some progress I suppose: deleted agent.db, started up again under the admin account. This time I actually got an error: BLZPTS00009. It told me to make sure I have enough hard drive space and try again. I have 90 gigs free. Heh.

    I guess tomorrow I google the error and see what I can try next.
     
  4. Prometheus

    Prometheus Administrator Staff Member

    I was thinking a bit more about this, and ideally you want to scorch the earth, get back to a pristine environment, and then install wow from scratch.

    The trick is you have to really scorch the earth. Leaving the wrong weed behind is enough to foul everything up.

    Still, if googling doesn't pop up with your error pretty clearly, or solutions posted already don't work, then your problem is complicated. You could try talking to Blizzard, but my guess is that they will have no clue what to do if your problem is complex.

    After doing an uninstall, I would do some additional "burning" to make sure you have no weeds:
    1. Delete all WoW-related folders. If these have odd security permissions, that could stop programs from writing data they need to, possibly leading to the misleading error something like "disk full", because the application assumes if it cannot write to the folder, that must be the problem. Check to make sure these are deleted:
      • In Computer/Local Disk (whatever)/ProgramData
        1. "Battle.net" folder
        2. "Blizzard" folder
        3. "Blizzard Entertainment"
        4. Anything else that looks associated with Blizzard
      • In Computer/Local Disk (whatever)/Program Files (x86)
        1. "World of Warcraft" folder
        2. That's probably all, but if you have other Blizzard applications, you may want to remove those too.
    2. Delete all WoW-related registry keys. This is a little scarier, but it's pretty similar to deleting folders in the file system. Follow these steps:
      1. Hit the start button and then click on the search text box
      2. Type "regedit" in the box.
      3. It should find a program called regedit that has an icon a bit like a rubix cube that a kid (or adult) has partially dismantled. If you can't find it, then stop, because you're stuck without this program, but it should show up.
      4. Run "regedit" by clicking on it. You'll get a list of "folders" on the left with funny long names. Treat them just like folders in a file system, and look for the following "folders" which it will call "keys":
        • HKEY_CURRENT_USER/Software/Blizzard Entertainment
          • Right click on "Blizzard Entertainment"
          • Select "Delete", confirm as needed and delete this key and all its subkeys
        • HKEY_LOCAL_MACHINE/SOFTWARE/Wow6432Node/Blizzard Entertainment
          • Right click on "Blizzard Entertainment"
          • Select "Delete", confirm as needed and delete this key and all its subkeys
      5. Close regedit.
    Basically you're making a valiant attempt to erase the operating system's memory of anything Blizzard ever existing. The above is fairly extreme, and if after that, you still cannot install, then I would consider re-installing the entire operating system since something very obscure is tripping up the install process, and whatever it is could affect other programs too. That means reinstalling every application you want to use, however, which is a pain.
    If that sounds extreme, it's only because I know from experience you can spend far more time trying to track down which of the 10 million options might be in the wrong state than it would take you to just burn everything and start from scratch, which will take you a day or so to do, and can mostly be done while you do other things.
     

Share This Page